Browser Requirements

The following are the minimum and recommended technical requirements for using the Scottrade client website:

Windows

Supported:

Current Windows OS and previous 2 versions

One of the following browsers:

  • Internet Explorer Version 11
  • Microsoft Edge (current and previous 2 versions)
  • Firefox (current and previous 2 versions)
  • Google Chrome (current and previous 2 versions)

Macintosh

Supported:

Current OS and previous 2 versions

One of the following browsers:

  • Safari (current and previous 2 versions)
  • Mozilla Firefox (current and previous 2 versions)
  • Google Chrome (current and previous 2 versions)